email
 Home  |  GL Blog  |  Forum  |  News  |  Tournament News  |  Conservation  |  Join  |  Youth  |  Site Map  |  Search  |  Contact Us  |  About Us  |  Advertise  |  Online Shopping  |  Donate to this site reluctant


Great Lakes Bass Fishing Forum  - extensive bass fishing home page specializing in Great Lakes, Michigan, Indiana, Ohio, Wisconsin, Minnesota, Illinois, Iowa, Pennsylvania, New York and Ontario bass fishing techniques, news, issues, conservation, bass fishing reports, bass biology, tournament strategy, bass fishing lure and fishing tackle, bass fishing forum and fishing message board, logistics, weather and safety, and product information.

        Great Lakes Bass Fishing Forum

              Your Great Lakes and Michigan Online
               Bass Fishing and Tournament Community.

Advanced search  
Please login or register.

Login with username, password and session length
Pages: [1]   Go Down

Author Topic: Motorguide tour digital issues...  (Read 2584 times)

0 Members and 1 Guest are viewing this topic.

motocross269

Motorguide tour digital issues...
« on: August 05, 2013, 06:17:47 PM »

My boat sat for a few weeks.. I took it out today and dropped the motor in the river and it wouldn't run at all.. Tried all 3 switch positions..Continous, momentary etc...
Checked the power at the plug and had 25 Volts, took the head cover off the TM and had 24 Volts there...Checked the power switch on the pedal and that is good also...

Any ideas other than a smoked TM...?? It is an 82 Tour Digital..2010
Logged

motocross269

Re: Motorguide tour digital issues...
« Reply #1 on: August 13, 2013, 03:22:19 PM »

TM was bad...Borrowed a buddies and it worked fine...
Took it to Wonderland last Tuesday...They still haven't looked at it yet hopefully I get some word on it soon...I called Motorguide and it is still under warranty so that is good...
Logged

Waterfoul

  • 7.89 New Personal Best!
  • Legend
  • *****
  • Offline Offline
  • Posts: 3,602
  • Is it tournement season yet???
  • View Gallery
Re: Motorguide tour digital issues...
« Reply #2 on: August 13, 2013, 05:26:44 PM »

Trade it in on a Minn Kota.   ;D
Logged
Addicted to fishing.  All the time, any species, anywhere!!  Especially in West Michigan!!!

Hoekset

Re: Motorguide tour digital issues...
« Reply #3 on: August 13, 2013, 09:16:09 PM »

I've got the same TM laying in my shop in a heap after it gave me trouble this year. Went to a fortrex. If anyone needs a tour 82 24V for parts, holler.
Logged

dartag

  • GLBass Friends
  • Legend
  • *****
  • Offline Offline
  • Posts: 3,169
  • Lola says " lets go fishing "
  • View Gallery
Re: Motorguide tour digital issues...
« Reply #4 on: August 14, 2013, 06:10:12 AM »

When the Elite series is on town next week there may be a service trailer.  They may be able to help out if they are not busy. 
Logged

motocross269

Re: Motorguide tour digital issues...
« Reply #5 on: August 14, 2013, 11:24:34 AM »

Trade it in on a Minn Kota.   ;D

Had a Maxxum pro on the Jag for 5 years with no issues.....
First experience with Motorguide is not so good..This TM can't have more than 30 hours on it...They are fixing it under warranty so that part of the service is good, but it took the Tech a week to get to it and another 5 days to get the parts...I ordered another motor with a longer shaft for a back up. I have some fishing planned for next week..I was saving my pennies for Power poles, so much for that...

There may be a reason why Motorguide has the Quick change Mount... ;)

It is Electronics and God knows that Trolling motors and Graphs are pretty much broke when they are new... ;D
Logged

Redbone

Re: Motorguide tour digital issues...
« Reply #6 on: August 15, 2013, 08:20:00 AM »

I am assuming water entered the motor area? Does it have a ducer built in?
Logged

motocross269

Re: Motorguide tour digital issues...
« Reply #7 on: August 15, 2013, 03:02:52 PM »

I am assuming water entered the motor area? Does it have a ducer built in?
No water in motor. Digital module went bad.
Logged

Lightningboy

Re: Motorguide tour digital issues...
« Reply #8 on: August 29, 2013, 03:55:01 PM »

Digital circuit board going bad is the result of moisture in the L/U.  Had it happen on a 2005 after three years of use; had it repaired then happened again two years later.  Needless to say, I went back to Minnkota.

Now I'm pretty hard on a TM, I'm no sissy about running it into bottom & shoreline cover if I need to.  But I've had two MG's in 15 years and neither one was impressive.  They always feel rickety & noisy, and don't come through weeds any where near as easy as the MK.  Only thing I don't like about my MK is the size on the bow, and that it weighs more then the MG.

BTW- I've got a MG digital tour 82 # with built in transducer in my garage too.  Only thing bad on it is the board in the L/U.  Anyone wants it for parts, free for the taking. 

Really, it's taking up space in my garage, please come take it off my hands.   ;D
Logged
Pages: [1]   Go Up
 

Advertisements


Visit Other Features of GreatLakesBass.com using the links below
 


Site Home | News | Bass Forum | Bass Tips | Articles | My Confidence Products | Tournaments

GL Blog | Weather | Fishing Pictures | Building Bass Boats | Conservation/Legislation | Bass Biology

Advertise | Site Sponsors | GreatLakesBass.com Store | Online Shopping

Site Map | Contact Us | Search | About Us | Links | Link to Us | Resources | Privacy Policy | Disclosure Policy
Stop Spam Harvesters, Join Project Honey Pot

VigLink badge