email
 Home  |  GL Blog  |  Forum  |  News  |  Tournament News  |  Conservation  |  Videos  |  Join  |  Youth  |  Site Map  |  Search  |  Contact Us  |  About Us  |  Advertise  |  Online Shopping  |  Donate to this site reluctant


Great Lakes Bass Fishing Forum  - extensive bass fishing home page specializing in Great Lakes, Michigan, Indiana, Ohio, Wisconsin, Minnesota, Illinois, Iowa, Pennsylvania, New York and Ontario bass fishing techniques, news, issues, conservation, bass fishing reports, bass biology, tournament strategy, bass fishing lure and fishing tackle, bass fishing forum and fishing message board, logistics, weather and safety, and product information.

        Great Lakes Bass Fishing Forum

              Your Great Lakes and Michigan Online
               Bass Fishing and Tournament Community.

Advanced search  
Please login or register.

Login with username, password and session length
Pages: [1]   Go Down

Author Topic: Universal Sonar issue  (Read 1413 times)

0 Members and 1 Guest are viewing this topic.

STEELERBOY29

Universal Sonar issue
« on: May 02, 2011, 04:36:50 PM »

I have an older Minn Kota PD trolling motor with the built in Universal Sonar.  I believe that the transducer is going bad.  My fish locator keeps losing contact with the bottom.  I know my locator is good, because I hooked it up to the dash and the unit was working fine, so I'm thinkink it's the US transducer.  Has anyone had this problem before?  Can you pull the US and install the newer US II?  Any input would be greatly appreciated.
Logged

thedude

  • Count Redbeard
  • GLBass.com Sponsor
  • Legend
  • *****
  • Offline Offline
  • Posts: 1,714
  • Curmudgeon at Large
  • View Gallery
    • West Michigan Bass
Re: Universal Sonar issue
« Reply #1 on: May 11, 2011, 01:43:51 PM »

i've never had a US trolling motor with a transducer that worked for more than a month. Save your money and just get a TM bracket and the factory transducer for the head-unit you wish to use.
Logged
West Michigan Bass www.westmichiganbass.com
Palehorse Custom Rods

rkillick

Re: Universal Sonar issue
« Reply #2 on: May 19, 2011, 09:01:15 AM »

if u pull it might void any warranty or not go back together very well. Then it is a bigger problem.
Logged

STEELERBOY29

Re: Universal Sonar issue
« Reply #3 on: May 19, 2011, 02:44:34 PM »

My TM is 5 years old, so the warranty is not an issue.  Getting it torn down, the right parts in, and put back together correctly is another story.  I went ahead and bought a steel mounting bracket kit.  I'll be mounting that tonight.  Thanks guys for the input.  Tight lines.
Logged
Pages: [1]   Go Up
 

Advertisements


Visit Other Features of GreatLakesBass.com using the links below



Site Home | News | Videos | Bass Forum | Bass Tips | Articles | My Confidence Products | Tournaments

GL Blog | Weather | Fishing Pictures | Building Bass Boats | Conservation/Legislation | Bass Biology

Advertise | Site Sponsors | GreatLakesBass.com Store | Online Shopping

Site Map | Contact Us | Search | About Us | Links | Link to Us | Resources | Privacy Policy | Disclosure Policy
Stop Spam Harvesters, Join Project Honey Pot

VigLink badge